Kali Linux: w3af

From OnnoWiki
Jump to: navigation, search

W3AF W3AF adalah aplikasi serangan web yang kaya fitur dan kerangka audit yang bertujuan untuk mendeteksi dan mengeksploitasi kerentanan web. Seluruh proses penilaian keamanan aplikasi otomatis dan kerangka kerja dirancang untuk mengikuti tiga langkah utama: discovery, audit, dan serangan. Masing-masing langkah ini mencakup beberapa plugin, yang dapat membantu auditor berfokus pada kriteria pengujian yang spesifik. Semua plugin ini bisa berkomunikasi dan berbagi data uji agar bisa mencapai tujuan yang diinginkan. Ini mendukung deteksi dan eksploitasi beberapa kerentanan aplikasi web termasuk injeksi SQL, skrip lintas situs, penyisipan file jarak jauh dan lokal, buffer overflows, injeksi XPath, perintah OS, misconfiguration aplikasi, dan sebagainya. Untuk mendapatkan informasi lebih lanjut tentang setiap plugin yang tersedia, kunjungi: http://w3af.sourceforge.net/plugin-descriptions.php.

Instalasi w3af dapat menggunakan perintah,

cd ~ apt install libcrypto++-dev apt-get update apt-get install -y python-pip w3af pip install --upgrade pip git clone https://github.com/andresriancho/w3af.git cd w3af ./w3af_console . /tmp/w3af_dependency_install.sh Jika sudah di instalasi, untuk menjalankan W3AF, masuk ke Kali Linux | Web Applications | Web Vulnerability Scanners | w3af (Console) atau menggunakan console untuk menjalankan perintah berikut:

w3af_console

Ini akan menempatkan anda pada mode konsol W3AF yang dipersonalisasi (w3af >>>). Perhatikan bahwa versi GUI dari alat ini juga tersedia di lokasi menu yang sama namun kami lebih suka mengenalkan versi konsol kepada anda karena fleksibilitas dan kemudahan dalam penyesuaian.

w3af>>> help

Ini akan menampilkan semua opsi dasar yang bisa digunakan untuk mengkonfigurasi tes. Anda bisa menggunakan perintah help kapan pun anda memerlukan bantuan untuk mengetahui pilihan spesifik. Dalam latihan ini, pertama-tama akan mengkonfigurasi plugin output, mengaktifkan tes audit yang dipilih, menetapkan target, dan menjalankan proses pemindaian terhadap situs target menggunakan perintah berikut:

w3af>>> plugins w3af/plugins>>> help w3af/plugins>>> output w3af/plugins>>> output console, htmlFile w3af/plugins>>> output config htmlFile w3af/plugins/output/config:htmlFile>>> help w3af/plugins/output/config:htmlFile>>> view w3af/plugins/output/config:htmlFile>>> set verbose True w3af/plugins/output/config:htmlFile>>> set fileName testreport.html w3af/plugins/output/config:htmlFile>>> back w3af/plugins>>> output config console w3af/plugins/output/config:console>>> help w3af/plugins/output/config:console>>> view w3af/plugins/output/config:console>>> set verbose False w3af/plugins/output/config:console>>> back w3af/plugins>>> audit w3af/plugins>>> audit htaccessMethods, osCommanding, sqli, xss w3af/plugins>>> back w3af>>> target w3af/config:target>>> help w3af/config:target>>> view w3af/config:target>>> set target http://testphp.example.com/ w3af/config:target>>> back w3af>>>

Pada titik ini, kami telah mengkonfigurasi semua parameter uji yang diperlukan. Target kami akan dievaluasi terhadap injeksi SQL, cross-site scripting, OS commanding, dan kesalahan konfigurasi htaccess menggunakan kode berikut:

w3af>>> start Auto-enabling plugin: grep.error500 Auto-enabling plugin: grep.httpAuthDetect Found 2 URLs and 2 different points of injection. The list of URLs is: - http://testphp.example.com/ - http://testphp.example.com/search.php?test=query The list of fuzzable requests is: [ 227 ]Vulnerability Mapping - http://testphp.example.com/ | Method: GET - http://testphp.example.com/search.php?test=query | Method: POST | Parameters: (searchFor="") Starting sqli plugin execution. Starting osCommanding plugin execution. A possible OS Commanding was found at: "http://testphp.example.com/search.php?test=query", using HTTP method POST. The sent post-data was: "searchFor=run+ping+-n+3+localhost&goButton=go".Please review manually. This information was found in the request with id 22. Starting xss plugin execution. Cross Site Scripting was found at: "http://testphp.example.com/search.php?test=query", using HTTP method POST. The sent post-data was: "searchFor=<ScRIPt/SrC=http://x4Xp/x.js></ScRIPt>&goButton=go".

This vulnerability affects Internet Explorer 6,Internet Explorer 7,Netscape with IE rendering engine,Mozilla Firefox,Netscape with Gecko rendering engine. This vulnerability was found in the request with id 39. Starting htaccessMethods plugin execution. Finished scanning process.

Seperti yang anda lihat, kami telah menemukan beberapa kerentanan keamanan serius dalam aplikasi web target. Sesuai konfigurasi kami, lokasi default untuk laporan pengujian (HTML) adalah /usr/share/web/w3af/testreport.html, yang merinci semua kerentanan termasuk informasi debug tentang setiap data request dan response yang ditransfer antara W3AF dan web target aplikasi. Kasus uji yang kami sampaikan di kode sebelumnya tidak mencerminkan penggunaan plugin berguna lainnya,profil, dan opsi mengeksploitasi. Oleh karena itu, kami sangat menyarankan anda untuk melakukan latihan melalui berbagai latihan yang ada dalam panduan pengguna, yang tersedia di

http://w3af.org/howtos/understanding-the-basics http://docs.w3af.org/en/latest/